PDA

View Full Version : Olympus Master 2.0



tspore
03-16-2007, 11:05 AM
Now we are also offering master.
IT has been brought to my attention, that many around the world cannot get it. I was on the phone with Olympus tech support, and he kept saying it was a issue on my end. But even after I showed him threads, and read him email he didn't believe me.
So I have gathered these programs and put them here until Olympus figures out what is wrong with its server.

Olympus Master 2.0 Windows (http://fourthirdsphoto.com/uploads/OlympusMaster20win.zip)
Olympus Master 2.0 Mac (http://fourthirdsphoto.com/uploads/OLYMPUSMaster2.dmg)

delaneyb
09-04-2007, 07:42 AM
Thankyou - been looking all over for the mac version!

DonR
11-18-2007, 11:57 AM
I went to the Olympus site the other day and had it downloaded Free in just a couple of minutes. I don't understand the adds I see selling Master 2.0 for $9.99 when all I had to do was download it.

Rockin Ronnie
11-20-2007, 12:43 PM
That would be the disk from Olympus Emporium and very likely version 2.04. Some folks like to have the disk, it seems.

I, for one, downloaded it like the OP but I noticed that one can only download version 2.0. A shame since it is almost impossible to update to latest version using dialup. Are you listening Olympus?

Ron

Johannes
11-24-2007, 06:20 AM
Master 2, ver. 2.05 for Mac OSX Leopard
http://downloads.olympus-europa.com/OM2/mac/OM205EN.dmg

Stubb
11-26-2007, 06:55 PM
I just installed Olympus Master 2.05 and no longer get the admin errors. Is there a need to install the OlympusDSCSCSIDriver option?

I am, however, getting the usual "Failed to communicate with the server" error on my MacBook Pro running 10.5.1 with my E-3 when I try to update the firmware.

Thanks,

Andreas

tspore
11-27-2007, 03:37 PM
I just installed Olympus Master 2.05 and no longer get the admin errors. Is there a need to install the OlympusDSCSCSIDriver option?
I am, however, getting the usual "Failed to communicate with the server" error on my MacBook Pro running 10.5.1 with my E-3 when I try to update the firmware.
Thanks,
Andreas

Me too. Basically, until Olympus fixes the software, we are stuck.
All the update did was give you a patch to use the current version of the software.

Dimitrios
04-26-2009, 09:57 AM
I just installed Olympus Master 2.05 and no longer get the admin errors. Is there a need to install the OlympusDSCSCSIDriver option?

I am, however, getting the usual "Failed to communicate with the server" error on my MacBook Pro running 10.5.1 with my E-3 when I try to update the firmware.

Thanks,

Andreas

Hi All,

First post here (just picked up an E-520 body + 2 lense system from Adorama).

I have a Macbook Pro running 10.5.6 and just updated to Master 2.1.1 and get the same error as indicated on here (server error (20))

Any thoughts from anyone?

Dimitrios

FinlandRobert
12-02-2009, 07:53 AM
Check to make sure you don't have anything in the proxy settings in your browser. For IE: Tools, Internet Options, Connections tab, LAN Settings button. Under the Proxy area, there shouldn't be anything there.
I noticed when I removed this information, OM 2 then connected to the internet without issue.