View Full Version : Troubleshooting of E-1's not recognizing lenses

07-18-2007, 10:21 AM
My E-1 seems to have lost the ability to recognize my lenses. They won't focus, and the camera won't adjust the aperture. Is there any way to service the lens contacts?

When this problem first happened, it was just the 50-200mm doing it, so I sent that in and paid $350 to have it fixed, which now appears to have been wasted, and I'd really like to take care of it myself if at all possible.

07-18-2007, 11:15 AM
Just to exclude the obvious, can you confirm you don't hold down the lens release button when you attach a lens? They should click into place, and if the release is held down they can rotate until the contacts no longer line up.

Did you get any documentation on what was "fixed" for your $350? I've not seen a contact failure before, but I can conceive of both mechanically straightforward, and non straightforward ways to cause one.

Bojan Volcansek
07-18-2007, 11:18 AM
First, be calm and check what acme suggested. And also write us what order repair says what has been done for 350USD.

also, tell us what is NOT working at moment? Neither lens?, Or just other lens, and repaired 50-200 IS working?

And finally call Oly Service, explain them what happened and ask them to fix your SYSTEM!

Yours Bojan

07-18-2007, 12:52 PM
The 50-200mm repair order said they replaced the contact block.

No, I don't hold the release button in when I change lenses.

Currently, these lenses are not recognized:

This one is recognized:
50mm macro

Yesterday I disconnected and reattached the 7-14 about seven or eight times trying to get it to work, and the aperture control was briefly displayed once, so I really think the contacts are going out on the camera.

I called Olympus, and they are going to try to work with me, but if anybody knows how to fix the contacts without shipping it back I would prefer to fix it that way to minimize the downtime. The E-1 is long out of warranty, and I'm reasonably handy with tiny screwdrivers and soldering irons.

07-18-2007, 01:27 PM
Just a thought, could the contacts be "gummed up"? I sometimes get this with circuit boards (and stereo jacks). A quick but gentle rub with a "Pink Pearl" eraser followed by a sparing wash with isopropyl on a Q-Tip cleans things right up.

Kyle Jones
07-18-2007, 03:47 PM
I've noticed that my 50mm is the tightest fitting lens I have so it might be telling that it's the only lens of yours that's recognized. It definitely sounds like a problem with the contacts on the camera to me.

07-18-2007, 04:18 PM

Thanks for saving me two weeks without my camera! The contacts looked clean, but I tried the cleaning you suggested, and it improved the situation so that all but my 14-42 lens worked. While I was doing that I noticed that the 4 screws that attach the mounting flange to the camera body seemed loose. A couple of them were no longer flush with the surface, so they were probably pushing the lens away from the contacts. I tightened up the screws and now all my lenses work great.


07-18-2007, 10:43 PM
A lesson for all of us--perhaps Tony should have a "troubleshooting" section where threads like this could be archived.

Bojan Volcansek
07-20-2007, 07:28 AM
A lesson for all of us--perhaps Tony should have a "troubleshooting" section where threads like this could be archived.

For now we don't have too much of those kind of threads to have new forum. But we can keep it in our Keepers forum.

Yours Bojan