Reference thread:

Well, after shooting that 400 shots on Friday after the lens repair, I thought that the lens was ok now. Took the E-3/12-60 combo to Vegas this past weekend. It happened again!

This time, I was outside under a strong afternoon sun, in between Luxor and Excalibur hotel. I pointed the combo at a tall dark building of the Luxor hotel, half pressed the shutter, the lens went OOF (but no continuous clicking, just OOF). I tried to refocus on something else lighter in color to see if the lens will come back into focus. Nope! Shut off the combo and turned it on again. Nope! Manually turned the focus ring to bring back the focus range to somewhere in the middle, the combo started to work again. I didn't dare to try to focus on that dark building again because I didn't know if that will damage the motor of the lens.

The lens continued to work flawlessly after that. I shot night scenes along the Strip. I shot under really dark conditions in Rio Hotel. No problem. The combo worked flawlessly the next as well when I was at Hoover Dam.

Soooo! What does this mean? It seems to me that this is now not a motor problem. I think this is more of a firmware issue between the lens and the camera.

I don't know. Should this be part of a bug report?