Results 1 to 8 of 8

Thread: OMD rear dial issue

  1. #1
    Join Date
    Mar 2009
    Location
    Sydney
    Posts
    1,124
    Thanks
    65
    Thanked 18 Times in 13 Posts
    Feedback Score
    0

    Default OMD rear dial issue

    The rear dial on my E-M1 is playing up. There is much written about this problem on other sites. Some have had theirs fixed only to have the problem return. Any thoughts?
    E-M1, 12-40mm PRO, 60mm macro, MMF-3
    E-450, 50-200mm SWD, 25mm f2.8, EC-14
    FL-50R

  2. #2
    Join Date
    Mar 2006
    Posts
    4,566
    Thanks
    1
    Thanked 129 Times in 89 Posts
    Feedback Score
    2 (100%)

    Default Re: OMD rear dial issue

    Quote Originally Posted by BobT View Post
    The rear dial on my E-M1 is playing up. There is much written about this problem on other sites. Some have had theirs fixed only to have the problem return. Any thoughts?
    Mine again now too. After the twirling therapy it worked well for a few months, lately it works sometimes.
    The E-M1 is certainly a flawed beast, more so than any other camera I have owned, but luckily my extended warranty lasts until later this year.
    Don

  3. #3
    Join Date
    Sep 2008
    Location
    Olympia, WA
    Posts
    580
    Thanks
    4
    Thanked 8 Times in 6 Posts
    Feedback Score
    6 (100%)

    Default Re: OMD rear dial issue

    I had mine fixed under warranty by Olympus in January 2015 and it has stayed fixed. So far, so good.

  4. #4
    Join Date
    Mar 2009
    Location
    Sydney
    Posts
    1,124
    Thanks
    65
    Thanked 18 Times in 13 Posts
    Feedback Score
    0

    Default Re: OMD rear dial issue

    I finally relented and took my E-M1 into Oly Hospital yesterday. The guy assured me that the problem is known (der) and they now have an improved part available. The camera is out of warranty but he was non-committal as to whether it will be done as a warranty repair. I'll be rather upset if they make me pay. We'll see.
    E-M1, 12-40mm PRO, 60mm macro, MMF-3
    E-450, 50-200mm SWD, 25mm f2.8, EC-14
    FL-50R

  5. #5
    Join Date
    Mar 2006
    Posts
    4,566
    Thanks
    1
    Thanked 129 Times in 89 Posts
    Feedback Score
    2 (100%)

    Default Re: OMD rear dial issue

    Quote Originally Posted by BobT View Post
    I finally relented and took my E-M1 into Oly Hospital yesterday. The guy assured me that the problem is known (der) and they now have an improved part available. The camera is out of warranty but he was non-committal as to whether it will be done as a warranty repair. I'll be rather upset if they make me pay. We'll see.
    Interesting. I think they probably will fix for free. After all it's a fault, not reasonable wear and tear.
    Don

  6. The Following User Says Thank You to Don Baldwinson For This Useful Post:

    BobT (09-07-2016)

  7. #6
    Join Date
    Mar 2009
    Location
    Sydney
    Posts
    1,124
    Thanks
    65
    Thanked 18 Times in 13 Posts
    Feedback Score
    0

    Default Re: OMD rear dial issue

    I put the camera in for repair late on 6th and had it repaired and delivered to my door on the morning of 9th. There was no charge despite being out of warranty. Fantastic service. 5 stars for Olympus Australia.
    E-M1, 12-40mm PRO, 60mm macro, MMF-3
    E-450, 50-200mm SWD, 25mm f2.8, EC-14
    FL-50R

  8. #7
    Join Date
    Sep 2010
    Location
    Tampa, Florida
    Posts
    538
    Thanks
    25
    Thanked 12 Times in 11 Posts
    Feedback Score
    2 (100%)

    Default Re: OMD rear dial issue

    Quote Originally Posted by BobT View Post
    I put the camera in for repair late on 6th and had it repaired and delivered to my door on the morning of 9th. There was no charge despite being out of warranty. Fantastic service. 5 stars for Olympus Australia.
    That is good news. Fixed for free and promptly also. Good for you!
    Steven R
    Tampa, Florida

    E-330, E-520, E-3

  9. #8
    Join Date
    Mar 2006
    Posts
    4,566
    Thanks
    1
    Thanked 129 Times in 89 Posts
    Feedback Score
    2 (100%)

    Default Re: OMD rear dial issue

    Quote Originally Posted by BobT View Post
    I put the camera in for repair late on 6th and had it repaired and delivered to my door on the morning of 9th. There was no charge despite being out of warranty. Fantastic service. 5 stars for Olympus Australia.
    Great result.
    I have seen a post somewhere which said that the part has been improved, and that is probably what you have installed now.
    Don

  10. The Following User Says Thank You to Don Baldwinson For This Useful Post:

    BobT (09-09-2016)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •